
ClusterView Application Help

ClusterView is a program which allows a MS-Windows user to browse through individual files and groups 
of files (named clusters). The files can have any size as they are never entirely stored in main memory 
and they can be search with approximative patern and/or regular expressions.

ClusterView has been written by Yves Roumazeilles and is available as shareware. You are invited to 
read now the user license.

To learn how to use help, press F1.

Introduction to ClusterView (short tutorial):

What is ClusterView?

What is a cluster?

How can I view and search a document?

How can I view and search a few more documents?

Creating a cluster?

Automatic clusters or dynamic clusters?

Why is ClusterView better for handling HTML or Netscape files?

ClusterView integration into Windows 95

Basic operations:

file operations

cluster operations

find operations

others

keyboard shortcuts

Other information:

Common questions and features

Copyright information

Requirements

FTP and Compuserve availability

Registering ClusterView

I would like to take the occasion to thank those who have been providing help (willingly or not) to the 
development of this application.



First, thanks to those who have been testing both ClusterView and the YGrep Search Engine, like 
Christian Lescuyer (who easily won his free life-long license for it by asking for approximative search and 
testing it).

Then, thanks to Microsoft for its excellent Visual C++ tools and Martin Heller for his nice "Programming for
Windows" book. If you are serious about Windows programming, you need both.

Last but not least, thanks to those who brought the approximative search concept (and algorithm) which is
central to today's ClusterView features: Ricardo Baeza-Yates and Gaston H. Gonnet who published the 
clear and innovative paper "A new approach to text searching" which was the basis of the YGrep Search 
Engine.



FTP and Compuserve availability

ClusterView is available through FTP (Internet file download). The reference storage is on the famous 
CICA server:

ftp.winsite.com                      directory: pub/msdos/win95/txtutil                          file: cl303w95.zip

Of course, you can also make an Archie search if you have access to it. And you will easily find the most 
appropriate file server near to you.

My preferred way of searching for it is: http://www.shareware.com/ . This web searcher is GREAT. If you 
want to ease things a lot more, just jump to my home page. You will find an updated entry and a pre-
configured pointer to search for ClusterView with www.shareware.com. You will then immediately be able 
to download to the apparently lowest load FTP server.

ClusterView is also available from Compuserve. You should look into the library of the "Windows 
Shareware Forum" (GO WINSHARE). ClusterView can be found (and downloaded) from the "Windows 
95/Win 32" section.



Requirements

ClusterView is an MS-Windows 32-bit program. Consequently, it requires a computer which can run 
Microsoft Windows 95 or higher. This includes the following general conditions:

an 80386 (or higher level) processor. However, a 80486 is highly recommended for MS-
Windows 95.

at least 2 megabyte of RAM. 4 megabytes are recommended for better operation. Many people 
think that running MS-Windows with less than 4 megabytes is crippling it. ClusterView does not 
need all of these, but you will appreciate to have them anyway if you're serious about using MS-
Windows. If you're running MS-Windows 95, you could consider having 8 megabytes, but do not
believe that MS-Windows 95 needs more than MS-Windows 3.x.

at least 1 megabyte of free disk space to install ClusterView and its support files. This can be 
reduced to 500 kilobytes if you really need it (by removing the help files and text files).

any screen monitor compatible with MS-Windows. Most standard screens meet this condition 
(Hercules, EGA, VGA, most SVGA resolutions, XGA, TIGA, etc.); check with your hardware 
manufacturer or consult the MS-Windows compatibility list provided by Microsoft upon request.

ClusterView has been tested compatible with MS-Windows NT v3.51. Please report if you see any 
problem there because I have not permanent access to Windows NT and I may have introduced a bug by
inadvertance.

This Windows 95 package is still backward compatible with Windows v3.1 or Windows for WorkGroups 
v3.11 if you provide the additonal WIN32S package from Microsoft. This way, you can still profit from the 
32-bits executable by installing (or having already installed) WIN32S on your MS-Windows machine. I 
suggest you avoid installing the v1.1 of WIN32S which proved riddled with bugs but can still be found 
almost everywhere (ClusterView can live with it, but...) and try and get WIN32S v1.30 or higher.

Note: ClusterView is only be available as a 32-bits program; The 16-bits program has been removed from
distribution and the 32-bits one is the only one left.



New Features in ClusterView v3.03

New features in versions 3.03

Addition of the splash window on startup.

Improved the uninstall feature to usability.

Solved a bug when running an external application on the document (with the "visual" command
[v keyboard command]).

Improved help file in bits.

New features in versions 3.02

Corrected a minor bug when searching with 2 errors (or more).

Since I switched to a new development environement (from Visual C++ 1.xx/2.x to Visual C++ 
4.0), I may have inserted new bugs. I hope not.

New features in versions 3.01

Insertion and removal of the ClusterView context menu entry is now customizable from the 
applicaiton menu.

Improvement of the Drag'n Drop feature for long file names.

Crude uninstall feature

New features in versions 3.00

Addition of the Web pages viewing mode with searching capability.

A major improvement in search speed has been obtained by changing the way the cursor is 
handled during the search operation.

ClusterView no longer has a 16-bit version. If you want to run it over Windows 3.1, users should 
now use the WIN32S package to emulate a 32-bit Operating System. It is suggested that they 
use either Windows 95 or Windows NT 3.51 (or higher).

New features in versions 2.04

Corrected a small bug in the YGrep Search Engine which prohibited a match when comparing 
the regular search expression ".*" (any character in any number including none) against an 
empty line. Minor but it was unpleasant to some people, for theoretical reasons.

Improved the manual (particularly the common questions and problems section which is now 
much better indexed).

Corrected a few idiosyncrasies in the part handling the long file names and the international file 
names.

This one was never released and has been kept at a development stage up to arrival of v3.00.

New features in versions 2.02 and 2.03

Performance was improved by about 30% in all fields when switching to true 32-bit 
programming. This means also that the same executable is usable in one of the following 
configurations : Windows 3.1 (with WIN32S extensions), Windows 95, Windows NT.

A number of improvements where added to the on-line Help file.

Addition of a new support address through Compuserve (101233,1032).

New features in version 2.01

Version added because of potential problems with a buggy 2.00 version which may be left on 
some servers.



New features in version 2.00

Handling of [Intl] section of the WIN.INI file for file info dialog box.

Minor code improvements.

On-line help minor extensions (mainly to Common Questions and Features).

Addition of the Edit menu to copy parts of the documents.

Search is now able to optionally wrap lines (at a small performance cost).

Users found 5 bugs, and (at my surprise :-) I could correct them.

Small improvements in the Help file.

Features in the future releases

I'm currently thinking of yet another way of searching data in files with the YGrep Search 
Engine. It then will be automatically applied to ClusterView. Keep on line.

You can ask.



Exiting ClusterView

To exit ClusterView, you can select the Exit option in the File menu or the Close option in the System 
menu.

Either way, in a dialog box, you will have to confirm that you indeed want to exit, and whether you want to 
save the currently open cluster (if there is one) and whether you want to save the configuration to the 
initialization file. The proposed default checked options take into account whether there is a need to save 
anything.

If you accept to save the present configuration, ClusterView will automatically go back to it next time you 
run it.

Notes
When there is no need to confirm quitting the ClusterView application (when the cluster and the 
configuration are already saved), the dialog box may not be displayed at all before quitting if the QuietQuit
option is set to TRUE in the CLUSTER.INI file.

To save the current cluster under another name than the one offered automatically by ClusterView, click 
on the Cancel button and then call the Cluster/Save As... menu option.

The selected set of options is dependent on the need to make the save. E.g. if the current cluster is 
modified but not saved, you will be automatically proposed to save it. Similarly, if some configuration or 
preferences (either internal or external) has been modified, the corresponding button will be crossed to 
propose a saving. You can select any other combination than the proposed one.



Cluster File Format

Cluster files are standard text files with a structure similar to Windows initialization files (see also help 
about the ClusterView initialization file CLUSTER.INI). However, some sections and entries are used or 
necessary for such a file to qualify for a Cluster file. Its file format is described here. However, remember 
that ClusterView is the best tool to generate legal Cluster files (using its create/edit/save capability).

A Cluster file is a special ASCII file that contains entry-value pairs representing run-time options for the 
applications.

The format of the file is following the general rule:
[section]
entry=value
   ...

Example
The following is the content of an example CLUSTER.INI file as it may be provided on the ClusterView 
distribution disk.

[Information]
Creator=ClusterView
Description=Any kind of text is welcome here.
Check=OK

[Contents]
Number of files=2
File1=DOC1.TXT
File2=C:\USER\JOHN\DOC2.DOC

Explanation
Each of the entries shown above will be now described.

[Information] Creator=<string>

This entry is necessary for ClusterView to recognize that this is a Cluster file. The exact <string> is left to 
application and user choice, but it must not be empty. ClusterView fills it automatically on Cluster creation 
with a string beginning with "ClusterView". Any file not containing this entry is automatically refused as 
non cluster.

If you manually create a cluster (using a text editor like Notepad), you are advised to insert a line similar 
to: Creator=MyName
[Information] Description=<string>

This entry is not necessary for ClusterView to recognize that this is a Cluster file. The <string> value can 
be any string. It is used as the description string of the Cluster. There is no checking done by ClusterView 
on this string, but ClusterView let you edit it.

The use of this field is left to the user (or another application) appreciation.

[Information] Check=<OK|string>

This entry is not necessary for ClusterView to recognize that this is a Cluster file. The value must be 
different from "OK" if the creator has a reason to believe that the Cluster file format is corrupted for some 
reason. This may be the consequence of a writing error detected by ClusterView when saving the Cluster.
In this case, the value is set to "KO". However, this is not necessarily recognized by tools reading the 
cluster.



[Contents] Number of files=<number>

This entry is not necessary for ClusterView to recognize that this is a Cluster file. The value must be a 
valid integer describing the number of available file entries shown next. ClusterView will accept Cluster 
files with invalid values there. However, to insure that other applications work well with it, ClusterView fills 
this field with the correct value when saving a Cluster.

[Contents] File1=<file_name>

This entry is necessary for ClusterView to recognize that this is a Cluster file. Only empty cluster can have
no File1 entry.

The document list of the Cluster is built from the list of File<i> entries. If there are N documents, all 
entries from File1 to FileN must be present. E.g. for three documents all File1, File2, and File3 
entries must be present (even if they are not in numeric order).

The value for a FileX entry must be a valid file name. If it is not, the Cluster cannot be recognized 
properly. The only exception is when you want to build dynamic clusters. You will then use file names 
including either of the MS DOS wild characters (* or ?). The following is an exemple of a dynamic cluster 
designed to include all TXT files as documents.

[Information]
Creator=Manual
Description=Test of a dynamic cluster

[Contents]
Number of files=1
File1=C:\DOCS\NEW\*.TXT

Note
It is generally considered harmless to build your own Cluster files by hand. However, it is often easier to 
use the ClusterView application and its Cluster Edit capability. But, please notice that building dynamic 
clusters is not possible with ClusterView (you must use a separate text editor).

For more about the Cluster file format, you can have a look at the examples which are on the distribution 
disk. Often, looking at an example gives you more useful information than any reference documentation. 
Don't miss the opportunity. It will save you many minutes looking for those silly little problems.

Even more to the point, or if you don't have the examples in the distribution disk you got from your BBS 
(in case of a partial distribution), you can write static clusters using the cluster create/edit/save capability 
of ClusterView. It will automatically create static cluster files which are following the building rules as 
strictly as possible.

For dynamic clusters, you can easily modify a static cluster with a text editor (e.g. MS Windows Notepad 
editor).



What is ClusterView?

ClusterView is a Windows 95 application designed to help handle text searching tasks in a group of large 
files. They can be either plain text files (like documentation files) or HTML source files (like those you can 
get back from Internet with the help of the "save page" feature of Netscape, Mosaic or the Internet 
Explorer). It's often difficult to handle all these different files, ClusterView allows to view them (for HTML 
files it provides a fast viewing mechanism with none of the flashy features of the full-fledged programs but
with a lot of flexibility), and then to search in the group of files.

The most prominent features are:

- grouping of documents in a structure named cluster. This allows to consult simultaneously various files 
you decide to link together according to your needs. Various operations (other than mere viewing) can be 
applied to the documents of a cluster. It's easy to build a cluster for all HTML documents of the cache 
directory for NetScape or Mosaic.

- approximative search based on Baeza-Yates algorithm to find a pattern which is only partly known (also 
known as search with erroneous patterns). For example, you can search for "pattern" with 1 error (at 
most) and it will match "pattern", "pittern" and "Pattern" while stepping over "lantern" (2 errors).

- regular expression search modelled on the Unix utility named GREP. It is particularly useful for complex 
searching with the help of its specific search "language" to describe the pattern you look for. For example,
you can search for "^pattern" to look for "pattern" at the beginning of a line; Or for "[pl]a[nt]tern" to look for 
either "pattern" or "lantern". Look into the Help file for an extensive description of the pattern language.

- files viewing is not limited by any constraints of size. You can be viewing anything you want (even 
gigabytes files if your computer has them readable - e.g. from a network).

- capability of using ClusterView with Windows 3.1 using the Win32S wrapping. This allows to get the 32-
bit performance without upgrading to Win95 or WinNT.

- some display processing allows to filter/modify the presentation of data to the document window.

- most of the keyboard commands are similar to / compatible with the ones from the Unix utilities named 
MORE and LESS.

See also
Cluster description, Fundamentals of ClusterView text searching, Preprocessing lines, Preprocessing 
HTML files.



What is a cluster?

A cluster is a group of files which are handled simultaneously by ClusterView. These files can be shown to
the user with ClusterView. You can manipulate them as a group (browsing into them, searching a word 
into them, etc.)

When you have opened a cluster, the ClusterView window will show its name in the caption bar, followed 
by :: and the name of the document currently opened. For example, if you are viewing the file 
DOCUMENT.TXT in the cluster CLUST.CLU, the caption bar will show "CLUST.CLU::DOCUMENT.TXT".

See also
Cluster file format, cluster operations.



How can I view and search a document?

The first step is to open the document with the menu command Document>Open... and select the 
document with the standard dialog box.

Then, the document is automatically displayed and you can select a find/search command with the menu 
command Find! or the menu option Find>Find...

You could also have opened the document the easy way: by dropping the file into the ClusterView 
window. ClusterView will automatically open any file droppped this way.

See also
Opening a few more files, the find dialog box.



How can I view and search a few more documents?

I suggest you first check that you open a group of dcuments the easy way: by dropping them onto the 
ClusterView window. But first, you will have to check into the preferences dialog box (from the 
Options>Preferences... menu option) that "Add file to current cluster" is checked.

Check it and then drop a few document files onto ClusterView.

Then, the first document is automatically displayed and you can select a find/search command with the 
menu command Find! or the menu option Find>Find...

Actually, what you've been doing is creating a cluster (your first cluster, maybe?).

See also
The find dialog box, cluster operations.



Creating a cluster

Basically, there are three ways of creating a cluster. They are shown here in the order of decreasing 
convenience in day to day operation and of increasing flexibility for power users:

Creation of a cluster by drag and drop
First, you will have to check into the preferences dialog box (from the Options>Preferences... menu 
option) that "Add file to current cluster" is checked.

Then, you will drop all the documents at once onto the ClusterView window.

Last, you will save the cluster you just built. Use the menu option Cluster>Save As...

Creation of a cluster by hand building
It is a common way of creating and modifying a cluster by calling the menu option Cluster>Edit... With the 
help of the dialog box which is presented to you, it's simple to add files in the document list, add a textual 
description at your convenience and save the resulting cluster with a name using the save buttons.

Creation of a cluster with an external file editor
Last but not least, a power user will find useful to have direct easy access to the cluster structure. It is 
stored into a textual file whose extension is commonly .CLU and whose format is left public. This is the 
only way you can build a dynamic cluster.

See also
Modifying a cluster, Format of a cluster file, Cluster operations, Dynamic clusters.



Automatic clusters or dynamic clusters?

A dynamic cluster is a special cluster which will permit to select documents not from a fixed list like all 
clusters, but with a file description like *.TXT (all documents whose file suffix is TXT). This is very 
convenient to easily open a large group of files (a full directory of text files from a CD-ROm or from a 
network directory) or when the file names are not known beforehand (when they are changed at irregular 
intervals like the files in the Netscape cache directory).

In all cases, you will have to create this special type of clusters with a text editor (ClusterView will 
recognize them but cannot build them).

See also
Dynamic cluster file format.



Why is ClusterView better for handling HTML or Netscape files?

On the Internet you can collect a few thousand documents in HTML format with the help of your web 
browser (be it Netscape, Mosaic, Internet Explorer or any other one). The sheer number reduces the 
ability you have to retrieve the useful information you know is here but is near to unfindable.

Drop all these documents onto ClusterView and start searching. ClusterView has the advantage (over 
other file viewers and file finders) of being able to wipe out/filter out/clean up the displayed HTML 
documents if you ask for it in the Options>Preprocess>HTML Tags... This allows a better search 
(ClusterView avoids finding hits into these strange codes designed for machine reading (and not for 
human reading)).

Check Options>Preprocess>HTML Tags..., drop a few Netscape documents onto ClusterView and start 
searching around.



ClusterView integration into Windows 95

File Explorer
ClusterView gives you the choice of installing itself into the File Explorer menus. This would allow you to 
hasten the search of data into some files.

If you click on the right mouse click over the Explorer or over the File Manager, a file menu will pop up. 
ClusterView installs a new entry at the top of this menu. It will contain a new entry named "YGrep 
Search..." and will allow you to immediately open a ClusterView instance to search a pattern into the 
selected file.

Install/Uninstall
As you may already have noticed, there is no installation procedure for ClusterView. You only have to 
uncompress the ZIP file into the appropriate directory (wherever you prefer, probably into one 
subdirectory of C:\Program Files). Anyhow, when first run, ClusterView will push proper uninstall 
information into the Registry database of your computer, in order to allow an easy uninstall process as all 
Windows 95 applications should do.

Uninstall will not delete the files (in the current version), but it will clean the Registry up behind itself to 
avoid leaving erroneous information into the Registry.

Windows 95 optimizations
ClusterView is now fully optimized for 32-bit operation and for inclusion into a 32-bit world like Windows 
95. It takes full advantage of this environment by an improved speed of search operation and of all 
operations (like menu handling, file handling, etc.)





YGREP
The YGrep Search Engine (YGREP.DLL) is the name of a Dynamic Library built for MS-Windows by Yves 
Roumazeilles and which can be found bundled with some applications like ClusterView.

The YGrep Search Engine hosts Approximative Search. The notion has been brought to light - at least 
mine - by Ricardo Baeza-Yates and Gaston H.Gonnet under the name of Shift-Or (or Shift-Add) search 
method. To my knowledge, the name of agrep (the YGrep Search Engine was first known as the AGrep 
Search Engine) was originally adopted by Sun Wu and Udi Manber for a Unix utility implementing a 
similar algorithm.

On the other hand, Regular Expression Search is based on old work by many researchers on automaton 
logic. Many implementations have already been found on Unix systems (under the application names of 
ed(1) and grep(1)) and others including Vax-VMS, DOS, CP/M, etc. They often differ from the original one
from Unix, but most power users now recognize easily the common syntax and appreciate its powerful 
capabilities.

I added some extensions which were not in the original Unix version. In that I was following the interface 
specification of various authors including David Conroy (original author of the superb MicroEmacs editor 
which I advise you to use in its more recent version by Daniel Lawrence for your MS Windows editing 
tasks), Ozan S. Yigit and Karl Hoorsfish. To that I had to add my own salt and pepper to get a working 
interface.

I apologize for omitting many of the other sources of my little knowledge in the field of programming.



Approximative Search
The approximative search is allowing you to find a text without knowing the exact form of what you are 
looking for. For example, you can look for text without taking into account the case of the letters (without 
making a difference between uppercase and lowercase letters).

The operation is centered on the fact that in most cases you know a text string which is "approximately" 
what you are looking for in your files. Additionaly, you are able to say that you expect this text string to 
have a certain number of errors.

For example, the string 'East' is approximately identical to 'West', but there are 2 errors (the first two 
letters of the words) and 2 matches (the last two letters of both words: 's' and 't').

Basic Operations
Searching for non-cased text



Searching for Approximative Text
The YGrep Search Engine offers to search for text even if the pattern you give is not exactly what you 
look for (you only have a faint idea of the exact spelling of the text). YGREP allows you to select an error 
level (the maximum number of errors you can accept when looking for the pattern in the text).

For example, you want the strings to look for are 'EAST', 'CAST' and 'FAST', but the following strings must 
not be matched: 'WEST', 'EMIT', 'COST'. This can be solved by increasing the number of errors accepted. 
Just propose the pattern 'EAST' with an error level of 1.

Operation
1 Position the window at the place you want to start your search.

2 From the Find menu, choose Find.

3 In the Find dialog box, type the pattern ('EAST').

4 To search the whole cluster (and not only the currently open file), select the Search Whole Cluster 
check box.

5 To search forward or backward from the cursor position, select the appropriate radio button.

7 To avoid the program taking into account the difference between upper and lower case letters, 
unselect the Check Upper/Lower Case button.

6 Ensure that the error level is 1, either by typing this value in the error level window or by selecting it 
in the pull down menu at the right of the number little window.

7 To avoid the program taking into account the difference between upper and lower case letters, 
unselect the Check Upper/Lower Case button.

8 To start the search operation, choose the OK button.

9 To close the Find dialog box without searching, choose the Cancel button.

For the users who want a command as short as possible, it is also possible to avoid using even the Find 
menu, and to go to the Find! menu (or to press Ctrl+F).

To search without the Find dialog box
1 Use the Find command, as in the preceeding procedure, to find the first occurence of the search 

text.

2 To find the next occurrence of the search text, choose Again from the Find menu.

For the users who want a command as short as possible, it is also possible to avoid using even the Find 
menu, and to go to the Again! menu (or to press F3).



Searching for Non-Cased Text
The YGrep Search Engine is limited in the maximum number of errors is accepts.

You can overcome this limitations (and use a lower error level) if you know that most of the errors will be 
in lettercase mismatch between the pattern and the text.

For example, you want to look for the strings 'West', 'WEST' and 'west', but the following strings must not 
be matched: 'East', 'east', 'EAST'. This cannot be solved by increasing the number of errors accepted. 
Just propose the pattern 'west' with an error level of 0 and do not check for upper/lower case.

During the search, the program do not take into account differences between an upper case letter ('A') 
and its lower case equivalent ('a').

Operation
1 Position the window at the place you want to start your search.

2 From the Find menu, choose Find.

3 In the Find dialog box, type the pattern ('west').

4 To search the whole cluster (and not only the currently open file), select the Search Whole Cluster 
check box.

5 To search forward or backward from the cursor position, select the appropriate radio button.

6 Ensure that the error level is 0.

7 To avoid the program taking into account the difference between upper and lower case letters, 
unselect the Check Upper/Lower Case button.

8 To start the search operation, choose the OK button.

9 To close the Find dialog box without searching, choose the Cancel button.

For the users who want a command as short as possible, it is also possible to avoid using even the Find 
menu, and to go to the Find! menu (or to press Ctrl+F).

To search without the Find dialog box
1 Use the Find command, as in the preceeding procedure, to find the first occurence of the search 

text.

2 To find the next occurrence of the search text, choose Again from the Find menu.

For the users who want a command as short as possible, it is also possible to avoid using even the Find 
menu, and to go to the Again! menu (or to press F3).



Regular expression search
The regular expression search is allowing you to find a text based on a description which will help you be 
more precise than with Approximative Search, but also more difficult to handle before you get used to it.

To give you a first look at what can be done (without going too far into the regular expressions syntax), 
here are a few of the possibilities.

You can search for pattern in the beginning (or in the end) of the lines, ignoring the similar patterns which 
appears in the middle. You can search for telephone numbers (XXX-X-XXX-XXXX), dates (XX/XX/XX), 
times (XX:XX), three-figure-numbers (XXX), or any other strictly formed field of numbers. but you can also
look for patterns a little more evasive like: four letter-words containing no figures, but beginning with an S 
letter either in lower- or uppercase and in the end of a line (that is defined by the pattern '\<[Ss][^0-
9_][^0-9_][^0-9_]\>$').

For an extended specification of the regular expression used, see also Regular Expressions



YGrep Search Engine regular expressions
The YGrep Search Engine regular expression routines support the full range of Unix regular expressions 
as defined in ed(1) and in grep(1).

Specification
 ^ A circumflex as the first character of the pattern forces matches to beginning of lines.

$ A dollar as the last character of the pattern forces matches to end of lines.

. A period anywhere in the string matches any single character.

* An expression followed by a asterisk matches zero or more occurrences of that expression.

+ An expression followed by a plus sign matches one or more occurrences of that expression.

- An expression followed by a minus sign optionally matches that expression.

[] A string enclosed in square brackets matches any character in that string, but no others. If the 
first character of the string is a circumflex the expression matches any character except the characters in 
the string. A range of characters may be specified by two characters separated by a -.

\< A backslash followed by an opening < matches the beginning of a word.

\> A backslash followed by a closing > matches the end of a word.

\ A backslash folowed by any other character quotes that character. This allows a search for a 
character that is usually a regular expression specifier.

Examples
^Windows matches all lines starting with Windows

Grep$            matches all lines ending with Grep

H..p                matches all lines containing Help, Hoop, Harp, etc.

^W.n              matches all lines starting with Win, Won, etc.

\$                        matches a dollar sign

fo*                    matches f, fo, foo, etc.

fo+                    matches fo, foo, etc.

[xyz]              matches x, y and z

a[^xyz]c    matches abc, arc and aXb but not axb

([0-9])            matches (0), (1), (2), (3), (4), (5), (6), (7), (8) and (9)

([0-9]*)        matches (), (0), (123), (2512), etc.

\<[Aa].*\>          matches any non-empty word beginning with either a or A



YGrep Search Engine Limitations
The YGrep Search Engine is limited in both the length of the pattern it can manage and in the maximum 
number of errors it accepts.

The length of the pattern is limited to 512 letters maximum.

The number of errors is limited to 256 maximum.

Both of them are limited by the following formula:

length_of_pattern <= 512 / (log2(number_of_errors) + 1)

The simple meaning of this formula is that if you have a long pattern, you cannot have a large number of 
errors. For example, with a 256 character pattern you must limit yourself to 1 error only. In most cases, 
this is not too limiting, but it should be noticed.

To partly overcome that constraint it is also possible to use the non-cased text search fonctionality.

Should you need to have a limitation placed higher or lower, please, contact the author for a customized 
version (this is not much more expensive than a standard package) or a source code license.





Cluster Operations

ClusterView is written to handle clusters and documents.

A cluster is a group of files which are handled simultaneously by ClusterView. These files can be shown to
the user with ClusterView. You can manipulate them as a group (browsing into them, searching a word 
into them, etc.)

How to...
Open an existing cluster

Find a text in a cluster

Create a cluster

Modify an existing cluster

Copy an existing cluster

Browse in a cluster



Opening an Existing Cluster
To open a cluster:

1 From the Cluster menu, choose Open... .

2 Type or select the filename.

3 Select the OK button.

The selected file must have the appropriate format for a cluster file or it will be refused and a message 
box will pop open. The easiest way to create a valid cluster file, is to use the cluster edit capability of the 
ClusterView application.



Creating a Cluster
To create a cluster

1 First, create an empty cluster choosing New... from the Cluster menu.

2 Second, edit the cluster using the Edit... from the Cluster menu.



Modifying an Existing Cluster
To modify an existing cluster, you first need to open one (see "Opening an existing cluster"). Then, you 
can modify it, choosing Edit... from the Cluster menu.

The dialog boxe displays the name of the cluster (Cluster Name field - which can be modified directly or 
using the Save As... button), the description string (Cluster Description field - which may be filled or not, 
and is modified directly), and the List of Documents.

- To empty the cluster under scrutiny, choose the New button.

- To start modifying another cluster, choose the Open... button.

- To save the modified cluster, choose the Save button (if the Cluster Name is appropriate), or the 
Save As... button (to change the Cluster Name before saving).

- To exit the Cluster Edit dialog box, choose the Exit button.

Changing the List of Documents
- To add one file to the List of Documents, select the position where you want to insert the new file 
in the List (if the List is empty this step is unnecessary), choose the Add File... button, then select the file 
in the file dialog box.

- To remove a file from the List of Documents, select the file to remove in the List, then choose the 
Remove File button.

- To move up or down a file in the List of Documents, select it in the List, then choose either the Up 
button, or the Down button according to your will. The list is immediately updated according to the choice 
you made.

Related topics
The Cluster menu contains some commands which allow to trigger the equivalent commands shown in 
the Cluster Edit dialog box. This is most interesting to apply commands to cluster you don't want to modify
as when you want to copy a cluster.

See also copying a cluster.



Copying a Cluster
To copy a cluster without modifying its contents:

1 From the Cluster menu, choose Open... .

2 Type or select the filename.

3 Select the OK button.

4 From the Cluster menu, choose Save As... .

5 Type or select the new filename.

6 Select the OK button.

The new cluster will have the same contents (the same document list) as the original cluster, but is stored 
under a different name.



Browsing in a Cluster
You can browse in a cluster (i.e. jump from one file to another) using one of the four available commands.

Going to the first file

Going to the previous file

Going to the next file

Going to the last file



Going to First File
This allows to jump back to the first file in the document list of the cluster.

This command is available both in the File menu (choose First File) and in the Cluster menu (choose First
File).

See also Going to previous file, Going to next file, Going to last file.



Going to Previous File
This allows to jump back to the previous file in the document list of the cluster. Using repetitively this 
command you can reach the first file of the cluster.

This command is available both in the File menu (choose Previous File) and in the Cluster menu (choose 
Previous File).

See also Going to first file, Going to next file, Going to last file.



Going to Next File
This allows to jump forth to the next file in the document list of the cluster. Using repetitively this command
you can reach the last file of the cluster.

This command is available both in the File menu (choose Next File) and in the Cluster menu (choose 
Next File).

See also Going to first file, Going to previous file, Going to last file.



Going to Last File
This allows to jump forth to the last file in the document list of the cluster.

This command is available both in the File menu (choose Last File) and in the Cluster menu (choose Last 
File).

See also Going to first file, Going to previous file, Going to next file.





Common Questions and Features

If you have some problem while using the ClusterView application, it's the right place to look for a 
solution. The most common problems encountered by users (both end users and developpers) are stored
in this unstructured database.

 Note 001 I am continuously bothered by this dialog box at starting of Clusterview

 Note 002 Clusterview never opens my clusters as clusters (it reads them as documents)

 Note 004 ClusterView does not recognizes the changes I put into CLUSTER.INI

 Note 005 After the end of a search, I get a "busy" cursor during some time- ClusterView has 
nothing more to do!

 Note 008 I don’t know where to get the latest version of ClusterView

 Note 009 My portable computer does not have the + and - numeric keys (no numeric keypad)

 Note 010 When I try selecting text, nothing appears to be highlighted

 Note 011 The Document>Browse menu command appears to select the wrong document when 
there are several of them with the same name

 Note 012 ClusterView sometimes appears not to find the files in the cluster

 Note 013 How do I get ClusterView 32-bits program working under MS-Windows 3.1?

 Note 014 How do I change the way a command is called (keyboard commands)?

 Note 015 My text documents are missing some parts

 Note 016 My HTML documents do not look the same in ClusterView and Netscape

If the ordinal numbers of the notes is revealing missing numbers in this list, this means that old bothering 
events have been removed in the life of the ClusterView application. This is certainly NOT because we 
are hiding some problems we would prefer not to reveal. This list is containing ALL the technical notes of 
significance for the current version of ClusterView.



I am continuously bothered by this dialog box at starting of Clusterview
The ClusterView application shareware edition package is distributed for an evaluation period of 30 days. 
The software tries and help you remember that you should register to have this dialog box removed.

Just register, and you'll get the License number to feed into the dialog in order to have it disappear.

See also
Registering ClusterView.



Clusterview never opens my clusters as clusters (it reads them as documents)
You certainly have built them "by hand" with an external file editor (maybe you tried to build dynamic 
clusters). In that situation, the most obvious error that we all do is to forget about the Creator field. 
Remember that this is used by ClusterView to differentiate between a document and a cluster. Include the
following in your cluster description:

[Information]
Creator=Manual

The contents of the Creator field have no importance. But it must not be empty or absent. Clusters built 
by ClusterView contain its name in this field in order to recognize easily this origin.

Another direction you should look is whether you decided to remove the preference "Try open as Cluster 
first" in the Options>Preferences menu option.



ClusterView does not recognizes the changes I put into CLUSTER.INI
You probably mean that you're twiddling the CLUSTER.INI file right from a text editor. You are advised 
avoiding it since all the entries can be modified from ClusterView itself.

Anyhow, remember that CLUSTER.INI must be in the same directory as CLUSTER.EXE (the executable 
file) and not in the Windows directory (e.g. C:\WINDOWS). This was made to avoid cluttering your 
Windows directory and to help you remove all traces of ClusterView if you need/want to extract it.

Saving the options from ClusterView is safe in that ClusterView always finds its way to the only correct 
version of CLUSTER.INI.



After the end of a search, I get a "busy" cursor during some time - ClusterView 
has nothing more to do!
I apologize for the apparent contradiction! ClusterView has still some internal structures to clear. So it 
needs a little time for that. On most computers you will hardly notice it after hours of use of ClusterView. 
Most users never do. However, on computers with (simultaneously) low processing power (the older 
ones) and low memory conditions (enough memory to run but not the amount suggested), you can 
observe the phenomenon if you ask for approximative search. This is due to the amount of time needed 
by MS-Windows to clear some of the structures. ClusterView is set waiting during 10 to 100 ms normally 
(barely noticeable), but can be forced in waiting up to 1 second (80386SX with less than 2 megabytes of 
RAM).



ClusterView has "memory leaks"
You don't need to read that one! The proble has disappeared...
This is only a place-holder. ClusterView has currently not a single memory leak, while some of the 
previous versions had. It was cumbersome to find. Now, I will avoid that creepy guy coming back on you. I
stand by you!

What does that mean?
In certain circumstances, ClusterView manages to eat up MS-Windows memory. This will certainly lead to
memory exhaustion if the circumstances are repeated enough times (many hundred times at least).

When does it happen?
It happens when ClusterView is run multiple times. The second and following instances will eat up about 
XXXX bytes of memory. These can total to a fair amount if you really try and run a lot of ClusterView 
instances. However, in the most usual situation, the user (you!) will not notice the situation.

What can you do about it?
You cannot do much. It is a programmer's problem to solve. I acknowledge I have not been able to 
identify it precisely enough to solve the problem. It will certainly be improved in a future release of 
ClusterView.

For the moment, and if you hit the wall of "not enough memory" you should quit Windows (and run it again
to clear if off).



I don’t know where to get the latest version of ClusterView
You can register and get it right from me!
Just kidding! But you can do it. Of course!

You can get it from a set of Internet FTP sites and various BBS
Consider the following article:

FTP availability

Many shareware libraries on CD-ROM now hold ClusterView. The SimTel CD-ROM you can get from 
Walnut Creek is one of these. Walnut Creek address is 4041 Pike Ln Ste D-386, Concord, CA 94520, 
USA. You can call at 1-800-786-9907 and +1-510-674-0783 (I try to keep this information up-to-date, but 
they may be moving some day or another...).

And, many BBS around the word keep updated copies of them (I keep on receiving messages from 
people telling ClusterView was either downloaded from or uploaded to some obscure (but active) BBS far 
from Europe.)



My portable computer does not have the + and - numeric keys (no numeric 
keypad)
Problem
This means that you don’t have access to the very nice + (resp. -) commands used to jump from one 
document to the next (resp. the previous).

Solution
You could force the insertion of these command through the specific personal commands of the 
ClusterView application, by creating a file named CLUSTER.KEY in the directory where you put the 
ClusterView executable file (CLUSTER.EXE).

It should contain the following lines:
+ next-file
- previous-file
For those of you unsure of the way to do this, the registered version of the ClusterView application 
contains a PORTABLE.KEY file in the .\OTHERS directory which only needs to be copied up into the 
ClusterView directory.



When I try selecting text, nothing appears to be highlighted
This only means that the current version of ClusterView does not mark the selection but it is working OK. 
Just copy it to the clipboard... Sorry!



The Document>Browse menu command appears to select the wrong document 
when there are several of them with the same name
When the cluster contains two or more documents with the same name, it appears that 
Document>Browse will always select the first one independently of the actual position in the cluster. This 
is either a "known bug" or a "feature" depending on the way you look at it. Anyhow, the cause of the 
problem comes from Windows handling of "ComboBoxes" and I cannot do anything about it for the time 
going.



ClusterView sometimes appears not to find the files in the cluster
This most certainly comes from the fact you build it (or modified it) without ClusterView. I guess you used 
a standard text editor. The most common situation appears when you insert relative file names (e.g. .\
file.txt) instead of absolute file names (e.g. C:\usr\cluster\samples\file.txt).

The obvious solution is "rebuild the cluster from the Cluster>Edit menu command" or "use your text editor 
again to correct the misspelling or so".



How do I get ClusterView 32-bits program running under MS-Windows 3.1?
You need to add to your system the standard Microsoft WIN32S package. Most notably it can be installed 
(semi-transparently) by many applications which need it. ClusterView shareware package does not 
include WIN32S in order to reduce redundancy and to reduce the cost of downloading the package 
through paying channels.

You should install WIN32S v1.1 or higher (prefferably higher, because v1.1 was riddled with bugs even 
though ClusterView does not stumble over them).



How do I change the way a command is called (keyboard commands)?
You should look into the special help section about keyboard assignement of functions.

See also
Keyboard default assignements, List of commands, Use of CLUSTER.KEY file.



My text documents are missing some parts
The most common case is when you left ClusterView in the "HTML tags out" mode. This mode is specific 
to Web Page display and should be used with caution on other files.

You can jump to this dialog box by calling the menu "Options>Preprocess>HTML tags". There is a help 
button on this dialog box.

See also
Filter HTML options box.



My HTML documents do not look the same in ClusterView and Netscape
That is true for all web browsers (Netscape, Mosaic, Internet Explorer and others). ClusterView is not a 
full-fledged HTML browser. It only tries to provide a sound approximation of HTML-built appearance in 
order to ease the search operations.





File Operations
ClusterView can deal with clusters, but it also accepts any kind of files (even non-text files).

How to...
Open an existing file

Get information about an open file



Opening an Existing File
To open a file:

1 From the File menu, choose Open... .

2 Type or select the filename.

3 Select the OK button.

The document file can be of any kind (text files or non-text files). However, non-text files may be displayed
with some characters replaced with the special Û sign.



Getting Information about an Open File
To get the full name, the size (in bytes), the last modification date and time of the currently open file:

1 From the File menu, choose File Info.

2 Select the OK button when finished.

The dialog box displays the requested information. You can close it pressing the OK button.





Find/Search Operations

ClusterView is intended to allow easy searching in the documents and the clusters of documents. In the 
find dialog box all the useful options are grouped and available to the user.

The following information can be entered:

Find What:
Provide the text to search (usually described as the <pattern »). If the Regular Expression item is 
checked, the pattern is interpreted as a Regular Expression string.

Forward/Backward Search:
Select the direction of the search. Forward means from the top to the end of the documents. Backward 
means from the end to the beginning of the documents.

Begin at First Line, First File:
Forces ClusterView to start search as indicated and NOT at the current viewing location.

Search Whole Cluster:
Forces ClusterView to jump over the documents limits. Allowing to search a whole cluster rather than a 
single document.

Wrap Search Over Line:
For hyphened text, allows to search a pattern which may be cut between two lines.

Regular Expression:
Forces ClusterView to use the Regular Expression Search language in the pattern to describe the search.
This is incompatible with the Approximative Search.

Match Case:
Forces a search with exact case match (the pattern « Case » will match the text « Case », but neither the 
text « case » nor <CASE »).

Search For Lines Which Do NOT Match the Pattern:
Self explicit.

Approximation Errors:
When set with a value different of 0, will allow an Approximative Search with the specified number of 
tolerated errors.

The following buttons can be pressed:

OK:
To accept the changes. They will be preserved in the CLUSTER.INI initialization file only when quitting the
application.

Cancel:
To abandon the changes.

Help:
To jump to the text you’re just reading now.



How to...
Find a text in a cluster

Fundamentals of text searching with ClusterView



Finding Text in a Cluster
It is possible to use ClusterView to look for a character, word, or group of words (or a specific pattern) into
all the files of a cluster. Two basic commands can be used.

To find text
1 Position the window at the place you want to start your search.

2 From the Find menu, choose Find.

3 In the Find dialog box, type the search text.

4 To search the whole cluster (and not only the currently open file), select the Search Whole Cluster 
check box.

5 To search forward or backward from the cursor position, select the appropriate radio button.

6 To force the search to take into acocunt the exact casing of letters, select the Check Upper/Lower 
Case button.

7 Select an error level for approximative search (0 is exact search).

7 To start the search operation, choose the OK button.

8 To close the Find dialog box without searching, choose the Cancel button.

For the users who want a command as short as possible, it is also possible to avoid using even the Find 
menu, and to go to the Find! menu (or to press Ctrl+F).

To search without the Find dialog box
1 Use the Find command, as in the preceeding procedure, to find the first occurence of the search 

text.

2 To find the next occurrence of the search text, choose Again from the Find menu.

For the users who want a command as short as possible, it is also possible to avoid using even the Find 
menu, and to go to the Again! menu (or to press F3).

To search with the mouse
When you double-click on a word in the displayed text, ClusterView immediately starts a search for that 
word using the others conditions as they were left by the previous search (e.g. if you were searching 
across a whole cluster, double-clicking will select a new pattern/text to search, but also across the whole 
cluster).

To cancel a search while it is running
If you decide that a long search operation must be cancelled (e.g. when searching something in a very 
large Cluster), you can press the ESC key. The search is stopped and a message box gives a 
confirmation of the cancellation.



Fundamentals of Text Searching in ClusterView
ClusterView is using a specific set of search operation whose fundamentals are most interesting for large 
search applications as it is often the case with large Clusters of Documents.

It is based on two different techniques: Approximative Search (also called YGREP search) and on 
Regular Expression Search.

For more information about these and the YGREP Dynamic Link Library used internally by ClusterView, 
select the topics in the preceeding paragraph.





Initialization File and ClusterView Configuration
The CLUSTER.INI file is used by ClusterView to optimize its operation in various fields. It is a special 
ASCII file that contains entry-value pairs representing run-time options for the ClusterView application.

The format of the file is following the rule of the other MS-Windows INI files:
[section]
entry=value
   ...

Various sections (and entries in each section) are defined for ClusterView.

Example
The following is the content of an example CLUSTER.INI file as it may be provided on the ClusterView 
distribution disk.

[ClusterView]
Yield=16
TabSize=8
DisplayStatusBar=TRUE

[Font]
Name=Arial
Size=12

[Directories]
Documents Init=C:\usr\cluster
Clusters Init=C:\usr\cluster

Lists
List of sections.

Hierarchical list of entries.

Alphabetical list of entries.



Initialization Sections
The definable sections are the following:

[ClusterView]

[Font]

[Directories]

[Preprocess Display]

[Drag and Drop]

If other sections are defined, they are ignored by ClusterView during its operation.



Initialization Entries (hierarchicaly sorted)
The definable entries (with their corresponding sections) are the following:

CursorWait in [ClusterView]

Yield in [ClusterView]

TabSize in [ClusterView]

QuietQuit in [ClusterView]

Editor in [ClusterView]

LicenseNumber in [ClusterView]

DisplayStatusBar in [ClusterView]

Name in [Font]

Size in [Font]

Documents Init in [Directories]

Clusters Init in [Directories]

In Char in [Preprocess Display]

Out Char in [Preprocess Display]

Filter At Start in [Preprocess Display]

Filter At End in [Preprocess Display]

Wrap Lines on Search in [Preprocess Display]

Preprocess HTML Tags Out in [Preprocess Display]

TryAsClusterWhenSingleDrop in [Drag and Drop]

AddFilesToCurrentClusterWhenDropped in [Drag and Drop]

If other entries are defined or if these ones are defined in another section, they are ignored by 
ClusterView during its operation.



Initialization Entries (alphabetically sorted)
The definable entries (with their corresponding sections) are the following:

AddFilesToCurrentClusterWhenDropped in [Drag and Drop]

Clusters Init in [Directories]

CursorWait in [ClusterView]

DisplayStatusBar in [ClusterView]

Documents Init in [Directories]

Editor in [ClusterView]

Filter At End in [Preprocess Display]

Filter At Start in [Preprocess Display]

In Char in [Preprocess Display]

LicenseNumber in [ClusterView]

Name in [Font]

Out Char in [Preprocess Display]

Preprocess HTML Tags Out in [Preprocess Display]

QuietQuit in [ClusterView]

Size in [Font]

TabSize in [ClusterView]

TryAsClusterWhenSingleDrop in [Drag and Drop]

Wrap Lines on Search in [Preprocess Display]

Yield in [ClusterView]

If other entries are defined or if these ones are defined in another section, they are ignored by 
ClusterView during its operation.



[ClusterView] Section
This section allows to optimize the performance of the ClusterView application in various fields.

The definable entries are:

CursorWait

Yield

TabSize

DisplayStatusBar

QuietQuit

LicenseNumber

Editor

If other entries are defined, they are ignored by ClusterView during its operation.



[Font] Section
This section allows to modify the display font which is used by ClusterView when showing the contents of 
a Document in its main window.

The definable entries are:

Name

Size

If other entries are defined, they are ignored by ClusterView during its operation.



[Directories] Section
This section allows to modify the operation of ClusterView when the application needs to access files on 
disk.

The definable entries are:

Documents Init

Clusters Init

If other entries are defined, they are ignored by ClusterView during its operation.



[Preprocess Display] Section
This section allows to configure the filtering/preprocessing options of the document display.

The definable entries are:

Preprocess HTML Tags Out

In Char

Out Char

Filter At Start

Filter At End

Wrap Lines On Search

If other entries are defined, they are ignored by ClusterView during its operation.



[Drag and Drop] Section
This section allows to optimize the behaviour of the ClusterView application in Drag and Drop operation.

The definable entries are:

TryAsClusterWhenSingleDrop

AddFilesToCurrentClusterWhenDropped

If other entries are defined, they are ignored by ClusterView during its operation.



Yield Entry - in [ClusterView] section
When ClusterView is executing a long operation (e.g. a search operation in a whole cluster), it may lock 
the system until the end of the operation. To reduce the inconvenience, ClusterView tries to allow other 
MS-Windows application get control of the machine at internally defined times. This is called cooperative 
multitasking.

The Yield entry allows the user to modify the default yield value in order to increase ClusterView 
performance (increasing the Yield value) or the MS-Windows performance (decreasing the Yield value).

Minimum value is 1, maximal value is 32767. Default value is 64.

Small values are advisable for systems with low-powered CPU (like an 80286) or with small available 
memory.

Example
To set the Yield value to a "very cooperative" level:

[ClusterView]
Yield=4

This allows other applications to get access to the processor at very frequent intervals.



CursorWait Entry - in [ClusterView] section
When ClusterView is executing a long operation (e.g. a search operation in a whole cluster), it may lock 
the system until the end of the operation. To allow the user (you!) to know that it is still working, the cursor
is changed to a changing image cursor.

The CursorWait entry allows the user to modify the waiting time between changes of the cursor in terms 
of explored lines.

Minimum value is 1, maximal value is 32767. Default value is 4.

Small values are advisable for systems with low-powered CPU (like an 80286) or with small available 
memory.

Example
To set the Yield value to a "very cooperative" level:

[ClusterView]
CursorWait=4

This allows fast redisplay of the changing cursor.



QuietQuit Entry - in [ClusterView] section
When quitting ClusterView, if there is no need to ask the user for a confirmation, and this entry is set to 
TRUE, the quit dialog box is not displayed.

Default value is FALSE.

Example
To allow a "fast quit" procedure:

[ClusterView]
QuietQuit=TRUE



Modify Right-Click File Menu Entry - in [ClusterView] section
No longer used.



Editor Entry - in [ClusterView] section
Describes the default editor to be used by the ClusterView application when calling the visual command.

There is no default value.

Example
To direct calling the standard MS-DOS editor (with version 5.0 or higher):

[ClusterView]
Editor=EDIT



LicenseNumber Entry - in [ClusterView] section
This entry is a text entry for storing the user license number. This should not be modified. Pleaase use the
dialog box at program start up to enter this license number when prompted.

There is no default value.



TabSize Entry - in [ClusterView] section
For displaying of the Tab charcater (or ASCII 0x09), ClusterView is able to handle various tabulation 
sizes. They are specified in number of middle-sized characters. The default is 8 (for 8 characters wide 
tabulations).

Minimum value is 1, maximal value is 32767. Default value is 8.

Values of 2, 3, 4 or 8 are advised in most cases.

Example
To set the TabSize value to a usual non-default value:

[ClusterView]
TabSize=4



DisplayStatusBar Entry - in [ClusterView] section
ClusterView allows to display a status bar at the bottom of the main window. It will show the positon of 
various indicators as "CapsLock", "NumLock", etc. This profile entry allows to select the presence of this 
bar.

Value can be either TRUE or FALSE. Default value is FALSE.

Example
To force display of the built-in status bar:

[ClusterView]
DisplayStatusBar=TRUE



Name and Size entries - in [Font] section
When ClusterView displays the contents of a Document in the main window of the application, it uses a 
specific font which can be customized with these entries.

The Name entry is the alphanumeric name of an existing font (even True-Type fonts are allowed).

The Size entry is the numeric value of the point size of the display font. The allowed values depend on the
selected font.

Example
To change the display font to a MS-Windows True-Type font like "Times New Roman" in 12 points:

[Font]
Name=Times New Roman
Size=12



Documents Init Entry - in [Directories] section
When ClusterView opens a dialog box to get access to a Document stored on disk, it uses this entry to 
select the default directory to search for Documents.

The Documents Init entry must be the alphanumeric name of a valid disk directory.

Default value is the directory where ClusterView was run from.

This entry can be changed at run time (between opening of each dialog box).

Example
To set the default initial directory for Documents to C:\ directory:

[Directories]
Documents Init=C:\

See also
Clusters Init



Clusters Init Entry - in [Directories] section
When ClusterView opens a dialog box to get access to a Cluster stored on disk, it uses this entry to select
the default directory to search for Clusters.

The Clusters Init entry must be the alphanumeric name of a valid disk directory.

Default value is the directory where ClusterView was run from.

This entry can be changed at run time (between opening of each dialog box).

Example
To set the default initial directory for Documents to E:\cluster directory:

[Directories]
Clusters Init=E:\cluster

See also
Documents Init



In Char Entry - in [Preprocess Display] section
ClusterView will be able to modify the appearance of the displayed documents. Any characters defined in 
the In Char entry and conveniently described in the other entries of the [Preprocess Display] will be 
replaced with a character given by the Out Char entry.

The In Char entry must be a single character.

There is no default value.

Example
[Preprocess Display]
In Char=+

See also
Out Char



Out Char Entry - in [Preprocess Display] section
ClusterView will be able to modify the appearance of the displayed documents. Any characters defined in 
the In Char entry and conveniently described in the other entries of the [Preprocess Display] will be 
replaced with a character given by the Out Char entry.

The Out Char entry must be a single character.

There is no default value.

Example
[Preprocess Display]
Out Char=-

See also
In Char



Filter At Start Entry - in [Preprocess Display] section
The filtering/preprocessing feature of ClusterView can occur at the start/beginning of all lines if this entry 
is set to TRUE.

The Filter At Start entry must be either TRUE or FALSE.

Default value is FALSE (do not filter character at start of line).

Example
[Preprocess Display]
Filter At Start=TRUE

See also
Filter At End



Filter At End Entry - in [Preprocess Display] section
The filtering/preprocessing feature of ClusterView can occur at the end of all lines if this entry is set to 
TRUE.

The Filter At End entry must be either TRUE or FALSE.

Default value is FALSE (do not filter character at end of line).

Example
[Preprocess Display]
Filter At End=TRUE

See also
Filter At Start



Wrap Lines On Search Entry - in [Preprocess Display] section
ClusterView can search over the end of line characters, when this entry is set to TRUE.

The Wrap Lines On Search entry must be either TRUE or FALSE.

Default value is FALSE (do not wrap).

Example
[Preprocess Display]
Wrap Lines On Search=TRUE



Preprocess HTML Tags Out Entry - in [Preprocess Display] section
ClusterView can filter out HTML tags from the web pages source text (i.e. clean up the pages yuo get out 
of Internet with Netscape, Mosaic or Internet Explorer), when this entry is set to TRUE.

The Preprocess HTML Tags Out entry must be either TRUE or FALSE.

Default value is FALSE (do not modify pages).

Example
[Preprocess Display]
Preprocess HTML Tags Out=FALSE



TryAsClusterWhenSingleDrop Entry - in [Drag and Drop] section
When a single file is dropped on the ClusterView main window, it can be handled in two ways. The first 
being to open it as a document in all case, the second being to try opening it as a cluster before using it 
as a document, this entry allows to choose between these two strategies. One means that you expect the 
dropped items to be documents, the second that you expect them to be clusters.

The TryAsClusterWhenSingleDrop entry must be either TRUE or FALSE.

Default value is TRUE.

Example
[Drag and Drop]
TryAsClusterWhenSingleDrop=FALSE



AddFilesToCurrentClusterWhenDropped Entry - in [Drag and Drop] section
When files are dropped on the ClusterView main window, they can be handled either as a documents to 
create a new cluster, or as an addition to the open cluster. This entry allows to choose between these two 
behaviours. Setting it to TRUE allows to build a cluster by successively adding files to an open cluster by 
drag and drop operation. Setting it to FALSE forces to build the cluster in one operation (bringing all its 
files in a single drop).

The AddFilesToCurrentClusterWhenDropped entry must be either TRUE or FALSE.

Default value is TRUE.

Example
[Drag and Drop]
AddFilesToCurrentClusterWhenDropped=FALSE





Keyboard Shortcuts
The following table shows the keyboard shortcuts and their corresponding menu and options. To help you 
remember them, the shortcuts are shown on the right part of the pull-down menus (when appropriate).

Shortcut Menu Option
F1 Help Help

Ctrl+F2     Read Profile (CLUSTER.INI file) information
Ctrl+Shift+F2     Write Profile (CLUSTER.INI file) information

Alt+F3 Find Find...
Alt+F3 Find!

F3 Find Repeat Last Find
F3 Again!

- File Previous File
+ File Next File

Home File First File
End File Last File



Mouse Operation
Double clicking on a word, trigger an automatic find forward operation for the word which was under the 
cursor.



Mouse Options
Not implemented... And may never be.

By choosing the Options menu, then selecting the Mouse... option, you access to a dialog box which 
allows to specify the exact meaning of the mouse clicks (both single and double). The user may be able 
to select its preferred operation for the use of the mouse in ClusterView.

The available options are the following:

Find! opens the find dialog box to start finding after selecting a set of options.

Again! search again with the already choosen find options.

(Nothing) no action is associated with this mouse operation.

To modify the associated mouse action, make the convenient set of selections, and choose the OK 
button.

To exit without changing the options, choose the Cancel button.





Keyboard operations compatible with the Unix utilities MORE and LESS
History and context
A very common set of tools for viewing files in Unix Operating System on a character terminal is known as
MORE and its follower LESS (improving on MORE). They share a common set of keyboard commands 
and LESS adds some commands which are compatible with what is known in a rather large number of 
utilities ranging from file viewers to text editors (like Emacs or VI).

While Windows is not specifically keyboard oriented, it allows its use for power users. Therefore, 
ClusterView has a set of keyboard commands which should be interesting to these users of high 
expectations in terms of usability and performance.

See also
Keyboard default assignements, List of commands, Use of CLUSTER.KEY file.



CLUSTER.KEY file
What is it?
You can create a simple CLUSTER.KEY file which will auto;atically redefine the operation of the keyboard
and the Keyboard default assignements for you.

There is a sample (and very simple) file for you to test it under the name PORTABLE.KEY. Simply rename
it CLUSTER.KEY, and it will solve the problem of portable PC which do not have the + and - key on a 
separate numeric keyboard. So it creates a correspondence between *any* + or - key on the keyboard to 
the normal function next-file and prev-file.

Basic syntax of the CLUSTER.KEY file
Here is the content you should expect to find in the PORTABLE.KEY file. It is the best example of the 
syntax to be used:

+ next-file

- prev-file

First the key sequence (any key sequence not including a space character or a tab), then a command 
name.

Syntax of the CLUSTER.KEY file
When you know that, you know everything you should. But there are a few cases when you will need 
slightly more. Therefore, here comes the detailed syntax description:

Each line of the CLUSTER.KEY file is independent from the others. It contains a correspondence 
between a keyboard command (a sequence of keys) and a command name. They are separated by a 
space character.

<CLUSTER.KEY line> =<keyboard_command> [space] <command_name>

A <keyboard_command> is built from any characters less the space character. Only two other 
characters have a special meaning: '\' (the backslash character) and '^' (circumflex).

'\' (the backslash character) followed by an octal number allows to introduced any key value (for power 
users only).

'^' (circumflex) gives an appropriate shortcut for Control-expanded characters (when you press the Ctrl 
key before a letter).

^A is Ctrl-A

^B is Ctrl-B

etc. 

A <command_name> is one of the command names described in the command list.



Keyboard default assignements
At start time, independently from the possible re-assignement by the user key file, Clusterview has a 
default table for keyboard commands.

Here is the list of all the commands which are bound to certain keyboard sequences.

<CR> forw-line

<LF> forw-line

e forw-line

j forw-line

n forw-line

^E forw-line

^N forw-line

k back-line

y back-line

^Y back-line

^K back-line

^P back-line

J forw-line-force

K back-line-force

Y back-line-force

d forw-scroll

^D forw-scroll

u back-scroll

^U back-scroll

, back-scroll

<Space> forw-screen

f forw-screen

^F forw-screen

^V forw-screen

b back-screen

^B back-screen

<Esc>v back-screen

z forw-window

w back-window

R repaint

r repaint

^R repaint

^L repaint

g goto-line



< goto-line

<Esc>< goto-line

p percent

% percent

G goto-end

<Esc>> goto-end

> goto-end

P goto-end

= status

^G status

:f<Ret> status

/ forw-search

? back-search

<Esc>/ forw-search-all

<Esc>? back-search-all

n repeat-search

N reverse-search

<Esc>n repeat-search-all

<Esc>Nreverse-search-all

m set-mark

' goto-mark

^X^X goto-mark

E examine

:e examine

^X^V examine

:n<Ret>next-file

:p<Ret>prev-file

:x<Ret>index-file

-f font-option

-d directory-option

-l line-option

-p preference-option

-q exit

-F font-option

-D directory-option

-L line-option

-P preference-option



-Q exit

^X^C exit

v visual

! shell

H help

h help

V version

q exit

Q exit

:q<Ret>exit

:Q<Ret> exit

ZZ exit

<Esc><Esc> exit

:q!<Ret> destroy

:Q!<Ret> destroy

See also
List of ClusterView keyboard commands (alphabetically sorted).



List of ClusterView commands (alphabetically sorted)
back-line
Move backward N lines along the document. When no argument is provided it defaults to one line of 
movement. This is equivalent to pressing the Up key.

back-line-force
Move backward one line along the document.

back-screen
Move backward N lines along the document. When no argument is provided it defaults to a full window of 
movement. This is equivalent to pressing the PageUp key (scrolling backward one window long).

back-scroll
Scroll backward N lines, default one half of the screen size. If N is specified, it becomes the new default 
size for the subsequent commands.

back-search
Search backward in the document for the N-th line containing the pattern. N defaults to 1.

The function calls the Search/Find dialog box with an initialized backward direction of search.

This is equivalent to calling the menu Find>Find... command then forcing the backward direction of 
search in the documents.

back-search-all
Search backward in the document for the N-th line containing the pattern. N defaults to 1.

The function calls the Search/Find dialog box with an initialized backward direction of search and an 
initilized « Search Whole Cluster » field.

back-window
Like back-screen, but if an argument is specified, it becomes the new window size (the argument is 
taken as the visible client area size measured in character lines (excluding the optional status or tool 
bars).

choose-file
Displays the Choose File dialog box which is also available through the document menu.

cluster-edit
Equivalent to the Cluster>Edit... menu command.

cluster-new
Equivalent to the Cluster>New menu command.

cluster-open
Equivalent to the Cluster>Open... menu command.

cluster-save
Equivalent to the Cluster>Save menu command.

cluster-save-as
Equivalent to the Cluster>SaveAs... menu command.

destroy
Fast exit (without asking confirmation as may be needed). See also exit.
directory-option



Equivalent to the Options>Directories... command.

examine
Examine a new file. If several files are given, they are all examined.

As a matter of fact, this is equivalent to executing a new command line, potentially reading more files in 
the currently open cluster.

exit
Normal exit (asking confirmation as needed).

file-close
Equivalent to the Document>Close menu command.

file-open
Equivalent to the Document>Open... menu command.

file-status
Equivalent to the Document>Status menu command.

first-file
Equivalent to the Document>First menu command.

font-option
Equivalent to the Options>Font... command.

forw-forever
Not yet implemented.

forw-line
Move forward N lines along the document. When no argument is provided it defaults to one line of 
movement. This is equivalent to pressing the Down key.

forw-line-force
Move forward one line along the document.

forw-screen
Move forward N lines along the document. When no argument is provided it defaults to a full window of 
movement. This is equivalent to pressing the PageDown key (scrolling forward one window long).

forw-scroll
Scroll forward N lines, default one half of the screen size. If N is specified, it becomes the new default size
for the subsequent commands.

forw-search
Search forward in the document for the N-th line containing the pattern. N defaults to 1.

The function calls the Search/Find dialog box with an initialized forward direction of search.

This is equivalent to calling the menu Find>Find... command then forcing the forward direction of search 
in the documents.

forw-search-all
Search forward in the document for the N-th line containing the pattern. N defaults to 1.

The function calls the Search/Find dialog box with an initialized forward direction of search and an 
initilized « Search Whole Cluster » field.



forw-window
Like forw-screen, but if an argument is specified, it becomes the new window size (the argument is taken
as the visible client area size measured in character lines (excluding the optional status or tool bars).

goto-end
Go to line N in the current document, default to 1 (last/end line of document).

goto-line
Go to line N in the current document, default to 1 (first/beginning line of document).

goto-mark
Followed by a lowercase letter, returns to the position which was previously marked with that letter (using 
set-mark). Followed by a ^, or a $, returns to the beginning or end of the document respectively. The 
marks are preserved when changing from one document to another inside a cluster (not if you reload a 
new document). You can then use the goto-mark to jump from one document to another.

help
Equivalent to the Help>Contents... command.

help-on
Equivalent to the Help>Search for Help On... command.

help-on-help
Equivalent to the Help>How to use Help... command.

index-file
Examine the first file/document in the cluster. If an argument N is given, examine the Nth document of the 
cluster.

last-file
Equivalent to the Document>Last menu command.

line-option
Equivalent to the Options>Line/Hyphen... command.

next-file
Equivalent to the Document>Next menu command.

percent
Go to a line near N percent of the total length of the document. This is equivalent to positionning the 
vertical ruler in the appropriate position. N should be between 0 and 100 (it is a percentage). If 
ClusterView receives an argument out of these bounds it will limit itself to 0-100%.

prev-file
Equivalent to the Document>Previous menu command.

preferences-option
Equivalent to the Options>Preferences... command.

repaint
Repaint the full screen. This command is only useful as a compatibility with other tools and to go around 
display bugs of either ClusterView (I don’t know of such a bug in ClusterView today) or the Windows 
Operating System or drivers.

repaint-flush



same as repaint.
repeat-search
Repeat previous search, for the N-th line containing the last pattern. The values of the dialog box fields 
are all kept for this repeated search.

repeat-search-all
Repeat previous search, but crossing the document boundaries around the full cluster. The effect is as if 
the previous search had selected the « Search Whole Cluster » option in the dialog box.

reverse-search
Repeat previous search, for the N-th line containing the last pattern, but in the reverse direction. The 
values of the dialog box fields are all kept for this repeated search except (of course!) the direction of the 
search operation which is reversed.

reverse-search-all
Repeat previous search, but in the reverse direction and crossing the document boundaries around the 
full cluster. The effect is as if the previous search had selected the « Search Whole Cluster » option in the 
dialog box.

set-mark
Followed by any lowercase letter, marks the current position with that letter. To retrieve the position, you 
should use the goto-mark.

shell
Opens a dialog box asking for a command line to type execute.

Windows applications can be run by giving their name. For example, entering WRITE in the dialog box, 
then pressing the OK button, will run the default minimal word processor of MS-Windows (MS-Write).

MS-DOS applications can also be run, but by giving their full file name. For example, entering 
COMMAND.COM in the dialog box, then pressing the OK button, will run an MS-DOS session under MS-
Windows; Entering WRITE.EXE in the dialog box, then pressing the OK button, will run the default word 
processing application under MS-Windows. Please, note that it is necessary to enter the full file name 
(including the suffix - .COM or .EXE in the examples).

When no application name is given, a shell program is run. It is selected following the above strategy:

First, the environment variable COMSPEC can provide the name of a shell program (usually 
COMMAND.COM).

Second, the environment variable SHELL can provide the name of a shell program.

Third, the initialization value (in the CLUSTER.INI file) [ClusterView] Editor can provide the name of a 
shell program.

By default (if none of the preceeding possibilities are fulfilled), ClusterView will call the Windows Program 
Manager. The only advantage of using the Windows Program Manager is that is present on virtually any 
Windows installation in the world. You are however, invited to use one of the other methods to designate a
more appropriate shell program (from a simple COMMAND.COM, to a superb shell program like the 
PharLap Front Runner shell).

status
Displays the File Status dialog box which is also available through the document menu.

version
Displays the About dialog box (including ClusterView and YGrep Search Engine versions, and your 
registered license number).

visual



Call a visual editor (a text editor) on the document currently displayed. The text editor program is choosen
in the following manner:

First, the environment variable EDITOR can provide the name of a text editor name.

Second, the environment variable VISUAL can provide the name of a text editor name.

Third, the initialization value (in the CLUSTER.INI file) [ClusterView] Editor can provide a text editor 
name.

By default (if none of the preceeding possibilities are fulfilled), ClusterView will call the Windows Notepad.
Be warned that if the document is actually a large file, Notepad will be unable to load it (it does not allow 
more than 64 kbytes documents). The only advantage of using the Windows Notepad is that is present on
virtually any Windows installation in the world. You are however, invited to use one of the other methods 
to designate a more powerful text editor (from a simple VI, Emacs, MS-DOS Edit, EDLIN, Norton Edit to a
full fledged text processor like Word for Windows, WordPerfect or AMI WordProcessor).



Shell command dialog box
In this dialog box, you can enter the command string you are ready to apply. For example, typing 
"write.exe" then pressing the OK button, will start the standard Windows 3.1 minimal word-processor.

If the command string is empty, the default shell is run (Program Manager, by default).

Some characters in the command string may have a special meaning:

The exclamation point (‘!’) put alone on the string will call back the previously run shell command. If this is
the first time you run the shell command, it will be equivalent to an empty command.





Initial directories dialog box

You have the ability to choose where ClusterView will choose its files (ckusters and documents) from. You
can select a default initial directory for each of them. This is not a limitation of your choice, but the location
where you are proposed to look when asking for opening either documents of clusters.

You can enter any directory in the text boxes of this dialog box.

The following information can be entered:

Clusters default directory:
The default location opened when the Cluster>Open... dialog box is called.

Documents default directory:
The default location opened when the Document>Open... dialog box is called.

The following buttons can be pressed:

OK:
To accept the changes. They will be preserved in the CLUSTER.INI initialization file only when quitting the
application.

Cancel:
To abandon the changes.

Help:
To jump to the text you’re reading now.



Line display options dialog box

ClusterView is able to do some minor preprocessing on each line before displaying it. The objective was 
to allow to replace some characters either in special position (beginning or end of line) or anywhere in the 
line.

You may give a single character as the hyphen as produced by the OCR software (« Text Hyphen » field), 
another single character to replace the hyphen with a more useful (or easy to read) character (« Display 
Char » field), and furthermore you can indicate where to search for the hyphen (in the beginning of the 
line, the end of the line), or you can disable the hyphenation option (« nowhere » button).

For example, replacing the hyphen text - with the display character * at the end of all lines, will allow the 
following document line:

how surprising this process may be, it co-

to be displayed as:

how surprising this process may be, it co*

The difference is small but may be very useful to some users. Honestly, most will never use this feature, 
but it is necessary for some.

The following information can be entered:

Text Hyphen:
Character to be found in text and to be replaced by:

Display char:
Replacement character.

Location of the hyphen character:
Select where the text hyphen is to be expected by ClusterView.

The following buttons can be pressed:

OK:
To accept the changes. They will be preserved in the CLUSTER.INI initialization file only when quitting the
application.

Cancel:
To abandon the changes.

Help:
To jump to the text you’re just reading now.



HTML filtering options dialog box

By default, ClusterView is configured to filter out any HTML tag in the documents it displays and 
searches. This means that you can read them more easily even if that's not up to displaying them in full. 
Here is part of a HTML file without filtering:

<HTML>
<HEAD>
<Title>My nice Home Page</Title>
</HEAD>
<BODY>
<p>
<CENTER><H2>Enter my home page</H2></CENTER>

No fun at all for us non-HTML freaks, isn't it? After filtering out the HTML tags, you'll read the following:

My nice Home Page

Enter my home page

Not very different, but readable (and usefully searchable).

The following information can be entered:

Filter HTML tags out:
Check this to "clean up" the HTML text.

The following buttons can be pressed:

OK:
To accept the changes. They will be preserved in the CLUSTER.INI initialization file only when quitting the
application.

Cancel:
To abandon the changes.

Help:
To jump to the text you’re just reading now.



Preferences dialog box

This dialog box is intended to select the options the user may want to modify in order to optimize the 
operation of the ClusterView application. This is considered as information for the power user. Most users 
will not find use of this data. Anyhow, both of them will find this dialog box more convenient than modifying
by hand the CLUSTER.INI initialization file.

The following information can be entered:

Multitasking priority:
Is the way for the user to interact with machine performance during long operations (mainly search 
operations). With a low value (e.g. 2), ClusterView will search faster, but the rest of the Windows 
applications will have less CPU time left for background operations like modem download or background 
printing. With a high value (e.g. 100), ClusterView will behave more smoothly (and more politely) with 
other Windows applications.

This is less important for true multitasking environments like Windows NT or OS/2.

Tabulation size:
Is the number of characters used as the default size for the tabulation (Tab or ASCII 0x09) character. The 
default value of 8 involves using the standard size of the tabulation character as defined in the original 
character font. It is usually equivalent to 8 medium-sized characters.

Mobile cursor waiting time:
Describes the time between each « rotating » cursor change. A higher value will reduce the speed of the 
cursor. The actual unit is a number of explored lines, but you are advised to try different values in order to 
find the best one for your computer 9and your personal taste).

Display status bar:
When checked, this will allow the display of the status bar at the bottom of the client window of 
ClusterView.

Try open as cluster:
When checked this button will allow ClusterView to try opening dropped files (or files given on the 
command line) first as clusters. If the file cannot be recognized as a valid cluster file, it is opened as a 
normal document.

When not checked, dropped files (and files given on the command line) are always opened as 
documents.

Add file to current cluster:
When checked, this button allows ClusterView to add dropped documents to the current open cluster 
rather than simply opening it as a document.

When not checked, dropped files are simply opened as documents rather than adding them to the already
open cluster.

The following buttons can be pressed:

OK:
To accept the changes. They will be preserved in the CLUSTER.INI initialization file only when quitting the
application.

Cancel:
To abandon the changes.

Save:



To immediately save the changes to the CLUSTER.INI initialization file. If you want to quit the dialog box 
AND save to the CLUSTER.INI initialization file, you should first save, then press OK.

Help:
To jump to the text you’re reading now.





Other Operations
Some of the ClusterView capabilities are less obvious and grouped here.

ClusterView configuration

Registration file

Drag and drop operation

Command line arguments

Furthermore, you can get direct access to the help capabilities either through the Help Contents option of 
the Help menu (this leads you to the introduction of this help file) or through the Search for Help On... 
option of the same Help menu (this leads you to the Search command of this help file).



Easter Egg Operation
An easter egg is the traditional name for these non-documented nice/funnny features of an application. It 
must not be counfounded with undocumented fonctions of the application. These would have some utility. 
On the contrary, the egg is of no use at all, but is generally either nice or funny but never useful (at least 
not willingly).

In all cases, the egg is hidden.

Try and find the one in ClusterView. If you EnAbLe it, you may like it.



ClusterView Configuration
ClusterView is configurable both through the use of its initialization file (whose name is CLUSTER.INI) 
and through the use of the Options menu. This allows you to easily optimize its operation and its 
performance.

The initialization file interface is more powerful (provides more options to the user) but is more difficult to 
use than the Options menu. The preferred interface for the user is the Options menu because it is more 
user friendly and providing all necessary information to avoid confusion.

The modifications made through the Options menu are autmatically saved back to disk into the 
CLUSTER.INI file at the normal end of the execution of the application (when you choose Exit in the File 
Menu or in the system menu).

For more information on these, please select either one of the keywords shown here.



Registration File
A default registration file is provided with ClusterView. To install it, follow the procedure:

1 Run the File Manager if it is not already running. To do this, you need to double click on the 
FileManager icon.

2 Switch to the drive and directory where the registration file is. Normally, you will find it on the 
distribution disk in the root directory (A:\).

3 Double click on the CLUSTER.REG registration file.

The ClusterView registration data is automatically added to your registration database. Next time you will 
run File Manager, all file whose suffix is CLU will be considered as ClusterView clusters. By double 
clicking on them, you will immediately open them with a new ClusterView application.



Drag and Drop Operation
This is an alternative to using the File Open... command and the Cluster Open... command from the 
application menu followed by the Open dialog box.

ClusterView is a Drag'n Drop client for File Manager. This means that if you take a file from the File 
Manager (selecting it with the mouse), drag it accross the desktop (keeping the left button pressed while 
moving the mouse pointer) and drop it on the ClusterView icon or window (when clicking up on the 
ClusterView main window), then, ClusterView will automatically open the file. If it can recognize a Cluster 
file, it will be opened as such. If not, the file will be opened as a Document.

ClusterView also allows multiple files to be dropped at the same time. They will be dropped as documents
in a cluster to group them.

For more about Drag'n Drop operation, you may consult your Windows 3.1 User's guide and File Manager
Help menu. You may also want to consult the help on configuring ClusterView for drag and drop operation
with the help of the CLUSTER.INI file.

See also
Cluster File Format



Command Line Arguments
If a file name is found on the command line at start time, ClusterView interpret it as a cluster name to 
open.

This, with the help of the registration file, allows to open automatically the cluster whose name suffix is 
CLU. In the File Manager, you only have to double click on the cluster to open it in a new session of 
ClusterView.



Font Selection
The display font can be choosen by the user through the Font choice in the Options menu. The dialog box
allows to choose a character font, if it must be normal, bold or italics, and its point size.

When the description of the font is finished you can click on the OK button. If you want to exit without 
altering the font currently selected, click on the Cancel button.



Line/Hyphen Options
ClusterView has a specific option for OCR hyphenated texts. It is able to modify automatically at display 
time the characters inserted at the start or the end of a line. The normal use is to modify the visual aspect 
of the hyphen which is often an unusual character added by OCR software.

The Line/Hyphen dialog box allows to select the hyphen character position in a line (either at start of line 
or at end of line), to show the hyphen character used in documents, to select the hyphen character to be 
used by ClusterView at display time.

Moreover, find operations are able to understand what an hyphen is and consequently it is optionally 
possible to wrap hyphenated words when searching for a pattern. This is done to allow the recognition of 
an hyphenated word (split to two different lines) as a single word and to allow an efficient search even in 
heavily hyphenated texts.

The modification process searches for the "In Character" at the specified position in lines, and replaces it 
with the "Out Character". The selections in the dialog box are fairly self-explanatory, but you have to 
remember that the character fields must contain one and only one character each for correct operation.





Non-text Files

Non-text files are files which contains not only standard printable characters. They can be data files, non-
ASCII files, non-Windows files, etc.



MS-Windows

MS-Windows is a trademark of Microsoft Corporation.



MS DOS wild characters

Two characters have a special meaning when inserted in a file name (two wild characters):

 The asterisk (*) represents a whole word or a group of characters.

 The question mark (?) represents a single character.

For more, read your MS DOS manual ("Using wildcards" or "wild characters definition").



Single User Registration Fee

Yes! We remind you the single user license fee is only a mere 95FF or US$20.



Registering ClusterView

ClusterView is distributed as ShareWare. It is not free or public domain. This means you may copy and 
distribute it freely but should you find it useful and use it beyond an initial evaluation period of 30 days you
are both legally and morally obliged to pay the registration fee or license fee.

Registrations should be sent to the author. Registered users will be sent a registration number and the 
ClusterView Professionnal edition, and will be informed of upgrades.

Yes, I want to register now!
Yves Roumazeilles - the author          France - money transfers / no credit cards

Public (Software) Library                            US - credit card orders

Compuserve SWREG registration Worldwide - CIS customers

What you get when registering
This is the important question. Here is the list:

- updated ClusterView application (the latest version anyhow) with single user license.

- an immediate notice when a new release is ready on the market.

- sample Cluster files with sample data.

- a registration number to identify yourself when contacting us.

- support through fax, phone and Email.

- access to our database of bug reports between releases. No release is done while this database 
contains even a single bug. I do not ship products I know contain bugs. But after shipping, users may 
discover ugly things in my code, and I trace them while I hunt them.

Remember that you can also ask for source licenses which will include full C++ source code for the 
Microsoft Foundation Classes, with full resources, definition files (everything you need to rebuild the 
ClusterView application from scratch). I cannot give more. Well! May be not "give", because you pay for it.
But, it's a bargain you could discuss with me if you need this.
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Registration form

Yves Roumazeilles - author

Select "File-Print Topic" from the menu bar to print this form. You will then be able to fill it. You can 
accompany you order with check. Credit cards are NOT accepted. You can order by phone or fax. But 
these numbers are for placing an order only!

Please use the form when ordering by mail.

NAME:    __________________________________________

COMPANY:    ______________________________________

ADDRESS:    ______________________________________
                                      ______________________________________
                                      ______________________________________

TOWN:    __________________________________________

CITY:    ____________________________________________

POSTCODE:    ________    COUNTRY/STATE:    ____________

TELEPHONE: _______________________

FAX:                              _______________________

EMAIL:                      _______________________

YGrep Search Engine
Single user license ($20 or 95 French Francs)                ________
Developer kit license ($295 or 1410 French Francs)     ________

BitList Engine
Single user license ($20 or 95 French Francs)                ________
Developer kit license ($295 or 1410 French Francs)     ________

ClusterView Application
Single user license ($20 or 95 French Francs)                ________

Shipping/Handling to Europe ($4 or 20 French Francs)                            ________

Shipping/Handling outside of Europe ($6 or 30 French Francs)     ________

==========

Sub-Total....     ________

European residents, apply VAT/TVA 18.6% (on sub-total)                    ________

==========

Total...........     ________

Here, shipping/handling costs are applied once even for multiple orders.

Make cheques payable to: Yves Roumazeilles

If you wish to pay in other currencies than French Francs or dollars, apply the normal change rate to 
French Francs and add a 6% increase to cover the costs my bank charges me. Thank you.

One way to get a cash payement is to use the help of cash senders like Western Union. They send 
money from one country to another in a matter of minutes between about 100 countries (25000 Western 



Union locations in the worldwide network). You can send the exact price (in French Francs) and I can get 
it immediately. In any case, call or mail me before you send anything in order to be sure I can go and get 
the money in a reasonable amount of time or to get the address of the nearest Western Union location.

Mail to:

Yves Roumazeilles
63 rue des Moines
75017 PARIS
          (FRANCE)

This address is also the place where you can get information of various kinds (about the status of the 
shipment of the order, registration options, product details, technical support, volume discounts, dealer 
pricing, site licenses etc).

Phone: +33-1-42.28.74.51
Fax: +33-1-30.37.38.07
Email: 101233.1032@compuserve.com (or roumazeilles@sagem.fr)
Compuserve ID: 101233,1032



Registration form

Public (Software) Library - registration service

Select "File-Print Topic" from the menu bar to print this form. You will then be able to fill it.

You can order with MC, Visa, Amex, or Discovery from the Public (Software) Library by callingYou can 
accompany you order with check. Credit cards are NOT accepted. You can order by phone or fax. But 
these numbers are for placing an order only!

Please use the form when ordering by mail.

NAME:    __________________________________________

COMPANY:    ______________________________________

ADDRESS:    ______________________________________
                                      ______________________________________
                                      ______________________________________

TOWN:    __________________________________________

CITY:    ____________________________________________

POSTCODE:    ________    COUNTRY/STATE:    ____________

TELEPHONE:    _______________________

FAX:                              _______________________

EMAIL:                      _______________________

YGrep Search Engine (item/product #11244)
Single user license ($20)                ________
Developer kit license ($295)     ________

BitList Engine (item/product #11245)
Single user license ($20)                ________
Developer kit license ($295)     ________

ClusterView Application (item/product #11246)
Single user license ($20)                ________

Shipping/Handling to Europe ($4)            per license     ________

Shipping/Handling outside of Europe ($6) per license     ________

==========

Sub-Total....     ________

==========

Total...........     ________

Contact one of the following:

by phone: 800-2424-PsL or Intl+1+713-524-6394
or by FAX: Intl+1+713-524-6398
or by CIS/Compuserve Email to 71355,470



or send by mail to:
PsL
P.O. Box 35705
Houston, TX 77235-5705
          (United States of America)

Remember! THE ABOVE NUMBERS ARE FOR ORDERS ONLY. You cannot expect any kind of support 
through them. If you call there, not only will you be left without an appropriate answer, but I will have to 
pay for the useless call. PLEASE, if you do not like the long distance calls involved with my address in 
France, do prefer sending a Fax (it won't hang your phone too long), sending an Internet Email (it won't 
cost too much, and Compuserve, BIX, AOL, etc. all have Internet gateways for your mail - I know you are 
paying for that, I won't overuse it, but any Email with the product name in its subject field gets a very high 
priority).

Any questions about the status of the shipment of the order, registration options, product details, technical
support, volume discounts, dealer pricing, site licenses etc, must be directed to:

Yves Roumazeilles
63 rue des Moines
75017 PARIS
          (FRANCE)
Phone: +33-1-42.28.74.51
Fax: +33-1-30.37.38.07
Email: 101233.1032@compuserve.com (or roumazeilles@sagem.fr)
Compuserve ID: 101233,1032

To insure that you get the latest version, PsL will notify us the day of your order and we will ship the 
product directly to you.



Registration instructions

Compuserve SWREG - registration service

This is the on-line registration service for Compuserve customers. It allows on-line, immediate, direct 
registration.

You should GO SWREG, to join the Shareware Registration Forum. You will then be asked the reference 
of the software product you want to get. Take it from the following list:

YGrep Search Engine v4.0 (item/product #)
Single user license ($20)            Id# 7811
Developer kit license ($295) No Id# yet

ClusterView v2.0 Windows 3.1 Application (item/product #)
Single user license ($20)            Id# 7812

ClusterView v2.0 Win32/WinNT/Win95 Application (item/product #)
Single user license ($20)            Id# 7814

Shipping/Handling to Europe ($4)            per license

Shipping/Handling outside of Europe ($6) per license

Any questions about the status of the shipment of the order, registration options, product details, technical
support, volume discounts, dealer pricing, site licenses etc, must be directed to:

Yves Roumazeilles
63 rue des Moines
75017 PARIS
          (FRANCE)
Phone: +33-1-42.28.74.51
Fax: +33-1-30.37.38.07
Internet Email: 101233.1032@compuserve.com (or roumazeilles@sagem.fr)
Compuserve ID: 101233,1032

To insure that you get the latest version, Compuserve will notify us the day of your order and we will ship 
the product directly to you.



Application Copyright and User License

The ClusterView application, the YGrep Dynamic Link Library (DLL) and their respective documentations 
are copyrighted (C) 1992-93-94-95-96 by Yves Roumazeilles. Their use is subject to the acceptance of 
the User License hereafter terms.

All the names used here are trademarks and registered trademarks of their respective owners.

Registration Fee

If you are using ClusterView after the initial 30 day evaluation period, your registration fee is necessary. 
Registered users will receive a registration number to remove the shareware notice box. This number will 
be applicable to any future release of ClusterView.

Please make checks payable in French Francs (or in U.S. dollars) to Yves Roumazeilles. Other 
currencies require excessive bank charges.

For use by corporations and other institutions, please contact the author for a licensing arrangement. 
Customizing and other special licensing are available upon request.

If you want to get the full source code of the application or of one of its components, please contact the 
author for a licensing arrangement.

Shareware User License

The program files and the associated documentation (e.g. this documentation) are copyrighted by the 
author. The copyright owner hereby licenses you to use the software given these restrictions:

* The program shall be supplied in its original, unmodified form, which includes this documentation.

* For-profit use without a license is strictly prohibited.

* The program may not be included - or bundled - with other goods or services. Exception may be 
granted upon written request only.

* No fee is charged. An exception is granted for not-for-profit user's group, which are permitted to 
charge a small fee (under $5) for materials, handling, postage and general costs. No other 
organization is permitted to charge any amount for distribution of copies of the software or 
documentation, or to include copies of the software or documentation with sales of their own 
products.

There is no warranty of any kind (either implied or not). The copyright owner may not be held liable for 
any damages, including any lost profits or other incidental or consequential damages arising out of or 
inability to use the software. By using the software, you agree to this.

Registered User License

The program files and the associated documentation (e.g. this documentation) are copyrighted by the 
author. The copyright owner hereby licenses you to use the software given these restrictions:

* The program and its documentation shall not be copied for other purposes than the normal backup 
and security needs. It certainly shall not be copied for distribution (the shareware version is available 
for that purpose).

* The program and its documentation shall not be used on more than one machine if for each acquired 
license. For additional machines, it is necessary to buy additional licenses. An exception is tolerated 



in the case of a portable computer associated with a desk computer. Then, and if the program is 
never used simultaneously on both machines, a single license is granted for the two machines.

* For-profit use without a license is strictly prohibited.

* The program may not be included - or bundled - with other goods or services. Exception may be 
granted upon written request only.

There is no warranty of any kind (either implied or not). The copyright owner may not be held liable for 
any damages, including any lost profits or other incidental or consequential damages arising out of or 
inability to use the software. By using the software, you agree to this.



Author Address
Registration fees can be sent to and the author can be reached at the following address (Email and duly 
paid registration fee is the preferred interface if you want a prompt answer):

Yves Roumazeilles
63 rue des Moines
75017 PARIS (FRANCE)
Phone: +33 1-42.28.74.51
Fax: +33 1-30.37.38.07
Email: 101233.1032@compuserve.com (or roumazeilles@sagem.fr)
Compuserve ID: 101233,1032

For comments, suggestions and bug reports, Email is available at:

101233.1032@compuserve.com
101233,1032 (Compuserve account ID)
Yves_Roumazeilles@compuserve.com (future alias)
Yves.Roumazeilles@SAGEM.fr
Roumazeilles@SAGEM.fr



What is Shareware?
"Shareware" is a way to distribute software while retaining the best of all worlds. People are invited to 
freely make copies of the software for evaluation purposes (it's cheap distribution). You are both legally 
and morally obliged to pay the registration fee if you start using the software after an initial 30 days 
evaluation period (the author gets money from its work). This respects the rights of the author while 
avoiding burdenning the users with high costs of traditionnal distribution channels.

Shareware is not free, Shareware is not public domain, but Shareware is not expensive.

Remember! The fee is small because the distribution is simple, but the user (YOU) must honestly pay the 
registration fee. This will allow future releases to hit the market as we have been able to do for a few 
years now.






